12/08/2009

Porque os códigos não funcionam no blog

Erro de htmlComo resolver problemas com códigos que não funcionam, muita gente sofre demais com isso e às vezes é por coisas bobas. Quando colocamos um código html, javascript ou algum estilo CSS(imagem de fundo, formatação de texto...) nem sempre o código funciona corretamente, então normalmente voltamos a pesquisar outro site com o mesmo código, porém muitas vezes o erro é fácil de resolver.
Veja os trechos de códigos abaixo:

<textarea rows="3" cols="12" onfocus="this.select()" onmouseover="this.focus()" name="textarea">


<marquee behavior="alternate" width="400" height="50" scrolldelay="2" scrollamount="2" direction="left" onmouseover="this.stop()" onmouseout="this.start()">Coloque aqui seu texto! ! !</marquee>


background-color: #66FFFF;
background-image: url(http://www.google.com.br/logos/perseids09.gif);




Usamos cores diferentes para você notar quantas vezes aparecem os sinais: < > # / ; = & ( ), além disso ainda as palavras precisa ser escritas corretamente pois como são comandos uma letra a mais ou faltando já trará problemas.

Na hora de fazer alguma alteração nestes códigos se apagar ou duplicar um desses símbolos o código apresentará algum problema, algumas vezes parando de funcionar, por isso já repetimos muitas vezes cuidado na hora de colocar e modificar os códigos.

Nossa sugestão é se for possível quando achar um código coloque no blog exatamente como copiou do site sem fazer alteração alguma nele, depois que visualizar e ver que funcionou então comece a fazer as modificações necessárias e durante as modificações não fique somente visualizando o blog, clique também para salvar assim se acontecer um imprevisto em certo momento não perderá seu trabalho todo.

Outro erro muito comum é na hora de copiar e colar principalmente para quem adora tecla de atalho ctrl C e ctrl V, já tive problemas por colocar um v a mais no meio do código, justamente por clicar o v antes do ctrl, sei que é um erro muito bobo, mas acontece.

A intenção desta postagem não é dizer que a culpa de todos os códigos que não funcionam são das pessoas que usam, mas já vimos muita gente perder tempo e passar muita raiva por causa de detalhes na hora de modificar um código, então tenha calma e preste muita atenção. Claro que os sites também erram, alias tudo que dissemos sobre os cuidados com os sinais no meio dos códigos também valem na hora de colocar um deles na internet.

Os trechos de códigos usandos como exemplos são: caixinha link-me, texto deslizando e imagem de fundo.

Veja também:

Personalizar a pagina cores e fontes
Imagens diferentes nos títulos do menu
Numeração nas paginas do blog
Sites para hospedar imagens
Hospedagem de sites grátis
Related Posts with Thumbnails

71 comentários:

  1. Você poderia me ajudar a resolver um problema do meu blog. Quando peço para salvar modelo, diz que existe num sei o que de xml aberta, o que é isso?
    Bjux

    ResponderExcluir
  2. Xênia da Matta
    é difícil dizer o que é porque pode ser diversas coisas.
    isso quer dizer que tem algo que foi aberto e não fechado por exemplo tem um código de um link mas no final faltou o </a>

    ainda em alguns códigos pode se resolver isso somente colocando um barra antes de fechar o comando com o sinal de maior assim />

    ResponderExcluir
  3. muito dificil esse codigos em HTML
    como ja citado aqui sempre tem que ter no final < a / >
    pois algums codigos são faceis de fazer assim posso usar no meu meu blog

    ResponderExcluir
  4. Olá fabiano.
    Estou com um probleminha com o link do meu blog, acho, e gostaria de contar com sua ajuda, me indicando um link para que mostre como resolver o problema, ou se vc souber me ajudar melhor.
    Tenho um blog,http://seriesdatvaberta.blogspot.com/
    e tenho parceria(traca de links) com outro blogs. Mas na maioria destes blogs, quando clikam em meu link, não abre meu blog. Aparece esta mensagem
    Feed Address: http://feeds.feedburner.com/Seriesdatvaberta

    HTTP Error (Code) and Message: (404) Feed not found error: FeedBurner cannot locate this feed URI.

    Vc sabe me dizer o que é isso e como posso solucionar. Ja tentei seguir os passos que eles mandam mas...
    pode até me indicar uns links que ensinam a consertar isso.
    Te agradeço muito se puder me ajudar.
    Um abraço e suceso.

    ResponderExcluir
  5. faz tempo que eu ando na sua cola. hj estou procurando joguinhos pra colocar em blogg, uma aluna ta querendo, lembrei de vc. achei que tinha visto aqui,há muito tempo. mas não foi. vou continuar a usca. bj. obrigada.

    ResponderExcluir
  6. Ronei
    veja se se tem algo errado nas configurações do feed(no blogger e no feedburner), mas até resolver isso sugiro que entre na pagina configurações do blogger e retire o link para o feedburner, assim o feed funcionará normalmente com o estilo padrão do blogger.

    ResponderExcluir
  7. Fabiano. Valeu pela visita, volte semrpe!
    Seu blog é um máximo, esta me ajudando muito. Likei vc, claro!!

    bjos

    ResponderExcluir
  8. Fabiano, lhe agradeço pela dica.
    Vou lá tirar o link.
    Sá mais uma pergunta:
    Isso pode trazer algum prejuízo para o meu blog?
    Um abraço

    ResponderExcluir
  9. Fabiano,
    Estou com problemas no meu blog!

    Entre as colunas e a parte de baixo do Blog tem um espaço indesejado. Como faço pra removê-lo?

    Você poderia dar uma olhada nele e me dizer o que está errado?

    http://ecomundoreciclando.blogspot.com/


    Vlw!"!

    ResponderExcluir
  10. Oi, você poderia me ajudar? Eu mudei o layout do me blog, para um que eu simplesmente AMEI, mas o link de comentário tá com problema, e fica dando erro, de modo que ninguém consegue comentar,e eu não quero mudar de layout, tipo, só se não tiver como consertar. Valeu(:
    http://naoseassuste.blogspot.com

    ResponderExcluir
  11. Mia
    escreva para nosso email e falaremos sobre isso

    ResponderExcluir
  12. Cara eu digito esses codigos para trocar o fundo mais não encontro, não aparece url(http...., será que pode me ajudar ?

    ResponderExcluir
  13. se for trocar o fundo do blog é perto do estilo body

    ResponderExcluir
  14. Não foi possível salvar o modelo
    Corrija o erro abaixo e envie o seu modelo novamente.
    Não foi possível analisar o seu modelo, pois sua formatação é inadequada. Certifique-se de que todos os elementos XML estão fechados adequadamente.
    Mensagem de erro em XML: Content is not allowed in prolog



    Me ajuda, eu não consigo mudar o template por causa disso! :(

    ResponderExcluir
  15. Nand.y e Mand.y
    é exatamente sobre esse tipo de coisa que falo na postagem é preciso ter cuidado nos detalhes, mas também pode ser falha no código.

    o melhor a fazer é tentar algumas vezes se não der certo procurar outro código.

    ResponderExcluir
  16. Eu fui colocar uma imagem no meu Cabeçalho, aí depois fui tentar tirar as margens do lado, pra nao ficar espaço sobrando e tals. Aí do nada a imagem foi parar do lado direito da tela e eu não to conseguindo centralizar ela. Já fiz de tuuuudo ,mas não consegui.
    Tem como me ajudar, por favor? *-*
    qualquer coisa entra no meu blog http://loohsoaresp.blogspot.com

    muuito obrigado, bjos :*

    ResponderExcluir
  17. Lorena
    é preciso fazer uma imagem no tamanho certo, mas entrei agora no seu blog e está centralizado, acho que já resolveu o problema

    ResponderExcluir
  18. Olá Fabiano, como vai? Estou colocando o código html no meu blog, o que você usa abaixo das postagens " Poderá também gostar de: ", mas quando insiro, nada acontece, é como se eu não estivesse adcionado nada. Na sua opinião, o que acha que ta acontecendo? Porque o código não funciona? Abraço!

    ResponderExcluir
  19. Na verdade até aparece o "Poderá também gostar de:" ( em inglês), mas nenhuma imagem aparece abaixo, fica tudo branco". Já esperi uns dois dias, pq pensei ser problema de atualização, mas nada apareceu. Se puder me ajudar ficarei grato.

    ResponderExcluir
  20. João Paulo Fernandes
    veja essa postagem sobre assuntos relacionados
    http://www.dicasparablogs.com.br/2009/10/mostrar-assuntos-relacionados-no-blog.html

    ResponderExcluir
  21. Cara me ajuda, no meu blog não aparece para ir para a próxima página ! SOCORRO O.O

    ResponderExcluir
  22. Vitor Santos o/ , veja aqui
    http://www.dicasparablogs.com.br/2009/07/alterar-texto-postagens-mais-antigas-e.html

    ResponderExcluir
  23. Olá ! por favor poderia me ajudar?

    fiz um emailmeform pro meu blog ja testei no site deu tdo direitinho . ai me deu o codigo eu copiei e colei no html do meu blog so qe ta dando erro ! =/

    Não foi possível analisar o seu modelo, pois sua formatação é inadequada. Certifique-se de que todos os elementos XML estão fechados adequadamente.
    Mensagem de erro em XML: The element type "input" must be terminated by the matching end-tag "".


    aparece isso ai oh /\
    help me pliiixx

    Brigda

    ResponderExcluir
  24. Administração
    está tentando colocar o código pela pagina editar html?

    use a pagina layout, adicionar gadget, html/javascript

    ResponderExcluir
  25. Bom, editei um html inteeeeeiro, demorei pra caramba pra terminar, e quando vou salva-lo no blog, aparece " Não foi possível salvar o modelo
    Corrija o erro abaixo e envie o seu modelo novamente.
    Não foi possível analisar o seu modelo, pois sua formatação é inadequada. Certifique-se de que todos os elementos XML estão fechados adequadamente.
    Mensagem de erro em XML: The element type "head" must be terminated by the matching end-tag "". "
    O que eu faço?

    ResponderExcluir
  26. popvintage
    como editou varias coisas é dificil saber onde está o erro, mas veja se não apagou a < / head> por engano.

    senão terá que fazer a edição novamente, mas salve a cada trecho que alterar assim fica mais fácil achar e corrigir o erro.

    ResponderExcluir
  27. Ola, o meu feed está mandando feed dos posts sem eu modificar ! Eu deletei um post que toda semana estava sendo mandada aos leitores, mas acabou sendo mandando o post seguinte, sem que eu modificasse ele. Não adianda eu deletar o post, e não sei o que modifico no Feed. Meu Ajudem por favor.

    ResponderExcluir
  28. Juvenal
    veja suas configurações no feedburner se está com o endereço correto do feed

    ResponderExcluir
  29. Oi Fabiano, é a primeira vez que peço ajuda aqui rsss, eu sempre estou me virando com códigos,mas desta vez não consegui ajeitar
    Depois de uma postagem que fiz, só copiei e colei, o título da postagem e os links e outros da barra lateral ficaram sublinhados e não consigo tirar
    Outra coisa é que não consigo mais mudar a cor da data e nem dos comentários está em azul e roxo
    Acabei mudando o modelo do blog pra ver se ajeitava e nada, se puder me ajudar eu agradeço
    http://valedosolencantado.blogspot.com/

    ResponderExcluir
  30. Isa Mar
    entre na pagina editar html e procure por:

    a:link, span.MsoHyperlink
    {color:blue;
    text-decoration:underline;
    text-underline:single;}

    apague esse trecho text-decoration:underline;
    text-underline:single;

    ResponderExcluir
  31. Oi Fabiano, eu procurei por a:link, span.MsoHyperlink
    {color:blue; e não tem no código, aí mudei só a outra parte mas não adiantou, só saiu o roxo dos comentários e ficou azul também
    Voltarei mais a noite pra ver se me deu mais alguma dica, obrigada!

    ResponderExcluir
  32. talvez tenha em algum outro lugar do código algo fazendo aparecer o sublinhado, procure por text-decoration:underline;

    e troque o underline por none

    ResponderExcluir
  33. Oi Fabiano, eu já tentei isso também e nada, inclusive não consigo mudar a cor da data, dos links e nem dos comentários, já até tentei o modelo de blog simples
    Obrigada pelas suas dicas, vou pesquisando, uma hora eu acho onde está o erro
    Abraços

    ResponderExcluir
  34. Oi Fabiano, a Cigana do Oriente é meu outro perfil de Isa mar rsss
    O que eu descobri é que ficou tudo em azul por que se transformaram em links, a data, os comentários e tudo e não estou conseguindo reverter o processo
    Abraços

    ResponderExcluir
  35. mas esse trechos que citou são mesmo link

    ResponderExcluir
  36. Fabiano, eu já te expliquei que ficou tudo sublinhado e data não é link,
    e não pode ficar tudo azul sem mudar de cor
    Muito obrigada pela sua boa vontade em ajudar, vou procurar um forma de reverter isso, abraços

    ResponderExcluir
  37. Cigana do Oriente
    a data é um link(Postado por Cigana do Oriente às Quarta-feira, Setembro 08, 2010)

    você pode alterar as cores neste trecho:

    a:link {
    text-decoration: none;
    color: #3778cd;
    }
    a:visited {
    text-decoration: none;
    color: #4d469c;
    }
    a:hover {
    text-decoration: underline;
    color: #3778cd;
    }


    mas tem um outro trecho no seu blog que também define os links

    a:link, span.MsoHyperlink
    {color:blue;
    text-decoration:underline;
    text-underline:single;}

    a:visited, span.MsoHyperlinkFollowed
    {color:purple;
    text-decoration:underline;
    text-underline:single;}

    veja que aqui na primeira parte tem text-decoration:underline; deveria trocar por none

    ResponderExcluir
  38. cara, você sabe se este efeito pode ser colocado no blog (blogspot)?

    http://www.realmadrid.com/cs/Satellite/es/Prehome_ES2.htm

    se souber, me fale como pf.
    agradeço desde já

    ResponderExcluir
  39. Schalke 04
    qual efeito? ou está falando do template? se for da aparência do blog quase tudo é possível ser feito só que leva tempo e precisa alterar varios códigos

    ResponderExcluir
  40. Amigo estou com uma dúvida cruel meus feeds do fedburner param de funcionar,erro 502, não sei o que faz
    renatopantanal@hotmail.com

    ResponderExcluir
  41. o blogger está mesmo apresentando esse erro, infelizmente não tem o que possamos fazer só esperar o blogger resolver o problema

    ResponderExcluir
  42. Meu amigo obrigado por responder, mais vou te pedir outro favor, meu blog foi contaminado por uma url que coloquei, logo recebi aquele aviso: o simples acesso a este site poderá danificar o seu pc! - amigo segui todos os passos da ferramenta para webmaster,logo após fiz um diagnóstico e o blog está beleza roda beleza em todos os navegadores com exceção do chrome, fiz de tudo até desinstalar e reinstalar eu fiz, mano, o pior é que a maioria dos blogueiros usa o chrome, com isto estou perdendo visitas, já entrei em contato com a google mais nada de resolver, só não entendo por que só o chrome? amigo se puder ajudar eu te agradeço!

    ResponderExcluir
  43. mas você encontrou a tal url? e retirar? se não precisa ver os gadgets que instalou recentemente e retirar para fazer testes e descobrir onde está o problema

    qual o link do blog?

    ResponderExcluir
  44. Sim amigão já retirei a url, no diagnóstico tá beleza, o meu blog é:
    http://pantanal-professorpantanal.blogspot.com/

    pode testar só não roda no chrome no mozila no explorer tá beleza.

    ResponderExcluir
  45. se já retirou a url com problema, talvez o seu computador esteja usando o histórico de internet, tente excluir o histórico e testar novamente

    usei o chrome para ver seu blog e não tive problemas

    ResponderExcluir
  46. desculpe amigo eu ser chato, mais como eu faço isto, e muito obrigado, outra dúvida amiga se quando ele estava com problemas outros visitantes visitaram o blog, este histórico pode ter ficado no navegador deles e seria por isso que eles continuam recebendo o aviso?

    ResponderExcluir
  47. infelizmente pode ser isso sim, alias acabei de escrever sobre o historico de internet que as vezes atrapalha os blogueiros

    Limpar Histórico de Internet - Evite erro no Blog

    ResponderExcluir
  48. Amigão estamos precisando de você urgente, veja bem mudamos o nome do nosso blog, e tinhamos colocado o nome do nosso blog rolando na aba dos navegadores, mais na hora de alterar este detalhe, meu nobre apareceu isto na hora de salvar o modelo.

    Não foi possível visualizar o modelo

    Corrija o erro abaixo e envie o seu modelo novamente.
    Mais de um item encontrado com o id: HTML70. Os IDs de itens devem ser únicos e exclusivos.
    Amigo nos ajude por favor!
    o endereço é:
    http://pantanal-professorpantanal.blogspot.com/

    ResponderExcluir
  49. PROFESSOR RENATO PANTANAL, você adicionou algum código que usa o nome html70 duas vezes por isso dá erro na hora de salvar, entao neste novo código use outro numero. mas salve uma copia do seu template antes, senão pode acabar perdendo algum gadget

    ResponderExcluir
  50. Foi realmente o que aconteceu, fui vistoriar e tinha dois html70, então coloquei html100 no outro e deu certo, mais uma vez muito obrigado.

    ResponderExcluir
  51. Olá. Preciso de uma ajudinha com meu blog, o corujasanimaisimpressionantes.blogspot.com. Eu não consigo por contador de visitas no blog sempre dá erro e diz assim:Não foi possível analisar o seu modelo, pois sua formatação é inadequada. Certifique-se de que todos os elementos XML estão fechados adequadamente.
    Mensagem de erro em XML: The end-tag for element type "html" must end with a '>' delimiter. Como resolvo isso?

    ResponderExcluir
  52. provavelmente tem um link no trecho que estava alterando... veja se não faltou nenhum sinal no código: aspas, < > deve ser esse o problema

    ResponderExcluir
  53. eu tento fazer uns codigos do couter strike mais nao funciona nenhum o que eu faço

    ResponderExcluir
  54. depende de qual código tentou usar... claro que apesar de erros na hora de copiar nem todos os sites mostram códigos que realmente funcionem... ou pode ser que algum dê problemas devido as tags do blogger

    ResponderExcluir
  55. Fabiano, bom dia!!!

    Eu coloquei no meu blog, a ferramenta CONTINUE LENDO, só que esta frase está aparecendo duas vezes na postagem.

    Onde eu errei?

    Desde já agradeço,

    ResponderExcluir
  56. mauricio
    veja neste link Fazer Resumo da Postagem com Miniaturas das Imagens

    lá mostra quando aparece duas vezes o leia mais

    ResponderExcluir
  57. Olá, Fabiano.
    Gostaria de uma ajuda enorme sua. Estava seguindo seus conselhos para conseguir resolver o problema do meu blog mais nada adiantou. Eu copio e colo o código no meu blog e salvo. Quando vou visualizar meu blog fica do mesmo jeito q estava antes não muda nada...

    Eu queria colocar esse layout aqui: http://template-miscellaneous-by-evelyn-regl.blogspot.com/2010/10/template-miscellaneours-peque-o-seu.html#comments

    Será que vc poderia fazer um teste ai para ver qual seria o problema? >_< Obrigada

    ResponderExcluir
  58. você poderia fazer esse layout trocando a cor de fundo... mas não tenho como explicar pois são muitas as alterações e ajustes...

    faça uma coisa por vez até seu template ficar do jeito que você quer

    ResponderExcluir
  59. Oii. Então eu não consegui aparece que não foi possivel salvar o modelo. Seria possivel eu apagar tudo que está la e voçê mandar tudo que tem ki ficar lá , seria mais facil. Beijos

    ResponderExcluir
  60. Sabrina e Jéssica
    não fazemos edições de templates para outros blogs...

    mas você pode trocar o seu modelo ou desfazer as alterações na pagina design do modelo

    ResponderExcluir
  61. Por favor, eu gostaria muito de uma ajuda com meu blog de download. Baixei um template da internet e não sei porque a caixa de busca em todo site ta bugando. Alguns filmes funcionam e outros não. Como posso configurar o html da busca? Se possível mande a resposta tbm pro meu e-mail, ratobeto@hotmail.com . Obrigado.

    ResponderExcluir
  62. @Betão talvez seja melhor trocar a caixa de busca, use a busca do adsense (google)

    ResponderExcluir
  63. Ola Estou com um erro no meu blog, que não consigo achar uma solução..
    Quando coloco a numeração nas paginas, o botão voltar não fica editado igual aos outros..
    é algum erro no codigo?

    ResponderExcluir
  64. esses códigos de numeração de pagina as vezes dão problemas no template do blog.

    já vi varios códigos para numeração de paginas o jeito é testar até achar um que funcione bem no seu template porque em todos tem gente dizendo que funcionou perfeitamente e outras pessoas falando que não deu certo

    ResponderExcluir
  65. Fabiano, eu já vi vários tutoriais, inclusive daqui, mas não descobri como resolver isso..

    Queria inserir uma imagem no fim de cada postagem, do mesma cor do plano de fundo. Mas o máximo que consigo é fazer isso:
    http://3.bp.blogspot.com/-Vg7y5ONlUCM/TxJJb_m9bdI/AAAAAAAAA1Y/brQytC53MoM/s1600/imagems.JPG

    E nem lembro mais como consegui, fui chutando no meio do Html. Daí, depois tentei fazer ele esticar até a borda e não consegui, deixando esse espaço branco entre ele e a borda.

    Queria é deixar assim: (Editado no paint)
    http://2.bp.blogspot.com/-KF4tL6Wo6dw/TxJJcj_GP9I/AAAAAAAAA1g/aPKizzbxeHA/s1600/imagemss.JPG

    Pode me ajudar?

    ResponderExcluir
  66. ai ñ entendi direito criei meu blog e tentei colocar um codigo de um jogo rpg da serto o que estou tentando fazer

    ResponderExcluir
  67. Ciel
    precisaria ver o html do blog para saber extamente onde é o lugar certo no código.

    dragon ball z rpg online
    nem todos os códigos funcionam no blogger

    ResponderExcluir
  68. Eu posso te mandar o código e vc tenta dar uma olhada? É só me dar a direção, estou perdido nisso há tempos.

    ResponderExcluir
  69. O meu problemas é esse que aparece no Blog: Deve haver uma e apenas uma pele no modelo, e encontramos: 0

    ResponderExcluir
  70. uma pele? não lembro de ver essa mensagem em nenhum lugar do blogger... tente explicar melhor seu problema, onde aparece isso? o que estava tentando fazer?

    ResponderExcluir